ナビ 公式 ヘルプ


 NADE APP

 トップ 最新 新規書込 検索

「サクラ」の和音入力支援的な
 なでしこ1 - カテゴリ無し

13 :雪乃☆雫




※テキスト音楽「サクラ」のストトン表記で、ちょっとだけ和音をラクに入力しよう的なものです。

#-----------------------------------------------------------------------
#「サクラ」の和音入力支援的な
#-----------------------------------------------------------------------

#-----母艦設計----------------------------------------------------------
!母艦設計=「母艦の可視はオフ」
母艦をウィンドウ背景色で画面クリア。
母艦のクライアント幅は320。
母艦のクライアント高さは240。
母艦のタイトルは「和音入力」
母艦のスタイルは「枠固定」
オフに母艦の最大化ボタン有効変更。
オフに母艦の最小化ボタン有効変更。
母艦を中央移動。
#-----------------------------------------------------------------------

#-----宣言--------------------------------------------------------------
音程とは配列=「シ{~}ラ#{~}ラ{~}ソ#{~}ソ{~}ファ#{~}ファ{~}ミ{~}レ#{~}レ{~}ド#{~}ド」
Noとは整数=0
MMLとは文字列=空。

#-----GUI------------------------------------------------------------
鍵盤マウス=「-1,-1」
鍵盤とはイメージ。
これについて
  可視はオン。
  位置は「10,30」
  幅は100。高さは170。 #白鍵(7)と白鍵+黒鍵(12)の最小公倍数=84*2+2
  マウス出た時は~
    鍵盤マウス=「-1,-1」
    -1,-1で鍵盤描画。
  マウス押した時は~
    もし、マウスX<50ならば、
      「{音程¥(マウスY/14を切り下げ)}ー」をMML演奏。
    もし、マウスX>50ならば、
      「{音程¥(マウスY/24を切り下げの全鍵変換)}ー」をMML演奏。
  マウス移動した時は~
    もし、鍵盤マウス=「{マウスX/50を切り下げ},{マウスY/14を切り下げ}」ならば、戻る。
    違えば、もし、マウスX>50ならば、
      (マウスY/24を切り下げ),-1で鍵盤描画。
    違えば、もし、マウスX<50ならば、
      (マウスY/14を切り下げの白鍵変換),(マウスY/14を切り下げ)で鍵盤描画。
-1,-1で鍵盤描画。
#-----------------------------------------------------------
入力パネルとはパネル
これについて
  位置は「110,30」
  幅は200。高さは170。

入力画面とはイメージ。
これについて
  可視はオン。親部品は入力パネル。
  位置は「0,0」
  幅は200。高さは170。
  マウス出た時は~
    鍵盤マウス=「-1,-1」
    -1,-1で鍵盤描画。
  マウス移動した時は~
    (マウスY/14を切り下げの白鍵変換),(マウスY/14を切り下げ)で鍵盤描画。
  マウス押した時は~
    もし、押されたボタン=「右」ならば、
      もし、マウスY≧168でなければ、
        「{音程¥(マウスY/14を切り下げ)}」をMML演奏。
    違えば、
      もし、マウスY≧168でなければ、
        ノート音程はマウスY/14を切り下げ
        ノート位置は「{(マウスX/50を切り下げ)*50+1},{(マウスY/14を切り下げ)*14+1}」
        ノート作成。
        「{音程¥(マウスY/14を切り下げ)}」をMML演奏。

線色は黒色。塗り色は白色。
入力画面の0,0から200,170へ四角。

線色は$999999
11回
  入力画面の1,14*回数から199,14*回数へ線。
線色は青色。
3回
  入力画面の50*回数,1から50*回数,169へ線。
#-----------------------------------------------------------
部品間隔は0
再生ボタンとはボタン。
その位置は「10,0」
そのクリックした時は~
  MML作成。
  もし、MML=空でなければ、MMLをMML演奏。

コピーボタンとはボタン。
その位置は再生ボタンの右側。
そのクリックした時は~
  MML作成。
  MMLをコピー。

貼付ボタンとはボタン。
その位置はコピーボタンの右側。
そのテキストは「{カッコ}サクラ{カッコ閉じ}へ貼り付け」
そのWはそのテキストの文字幅取得+10。
そのクリックした時は~
  MML作成。
  MMLをコピー。
  「*テキスト音楽{カッコ}サクラ{カッコ閉じ}」を窓アクティブ。
  「*テキスト音楽{カッコ}サクラ{カッコ閉じ}」へ『^v』をキー送信。

部品間隔は10。
確認エディタとはエディタ。
その位置は鍵盤の下側。
その幅は300。
#-----------------------------------------------------------
Rメニューとはポップアップメニュー。
Rメニューに『#親部品名,部品名,テキスト,ショートカット,オプション,イベント
-,削除メニュー,削除,,,ノート削除
-,-,,,,
-,上メニュー,オクターブ↑,,,「‘」でオクターブ変更。
-,中メニュー,オクターブ通常,,,「」でオクターブ変更。
-,下メニュー,オクターブ↓,,,「”」でオクターブ変更。』をポップアップメニュー一括作成。

*ノート削除
  ノート[ノート番号]→テキストは空。
  ノート[ノート番号]→可視はオフ。

*オクターブ変更(Aで)
  音符=ノート[ノート番号]→テキスト。
  もし、(音符の1文字左部分=「‘」)または(音符の1文字左部分=「”」)ならば、
    音符=音符の1から1文字削除。
  ノート[ノート番号]→テキストは「{A}{音符}」。
  ノート[ノート番号]→幅は48。
#-----------------------------------------------------------------------

母艦の可視はオン。
#-----------------------------------------------------------
*鍵盤描画(W,Bで)
  線太さは1。線色は黒色。塗り色は白色。
  鍵盤の0,0から100,170へ四角。
  yy=1
  7回
    もし、W=回数-1ならば、塗り色は$FFCCCC
    違えば、塗り色は白色。
    鍵盤の0,yyから100,yy+24へ四角。
    yy=yy+24。
  yy=1
  12回
    もし、回数=2または回数=4または回数=6または回数=9または回数=11ならば、
      もし、B=回数-1ならば、塗り色は$CCCCFF。
      違えば、塗り色は黒色。
      鍵盤の0,yyから50,yy+14へ四角。
    yy=yy+14

*全鍵変換(Aの)
  もし、A=1ならば、2で戻る。
  違えば、もし、A=2ならば、4で戻る。
  違えば、もし、A=3ならば、6で戻る。
  違えば、もし、A=4ならば、7で戻る。
  違えば、もし、A=5ならば、9で戻る。
  違えば、もし、A=6ならば、11で戻る。

*白鍵変換(Aの)
  もし、A=2ならば、1で戻る。
  違えば、もし、A=4ならば、2で戻る。
  違えば、もし、A=6ならば、3で戻る。
  違えば、もし、A=7ならば、4で戻る。
  違えば、もし、A=9ならば、5で戻る。
  違えば、もし、A=11ならば、6で戻る。
  違えば、もし、A=0ならば、0で戻る。
  違えば、A=-1で戻る。
#-----------------------------------------------------------
*ノート作成
  ノート[No]をラベルとして作成。
  ノート[No]→親部品は入力パネル。
  ノート[No]→ポケットはNo。
  ノート[No]→位置はノート位置。
  ノート[No]→テキストは音程¥ノート音程
  ノート[No]→透明はオフ。
  ノート[No]→幅は48。
  ノート[No]→高さは12。
  ノート[No]→背景色は$FFFF99
  ノート[No]→ポップアップメニューはRメニュー
  ノート[No]→マウス押した時は~
    ノート番号は自身→ポケット
    もし、押されたボタン=「左」ならば、
      自身→背景色は$999999
      ノート移動フラグはオン。
  ノート[No]→マウス離した時は~
    もし、押されたボタン=「左」ならば、
      自身→背景色は$FFFF99
      ノート移動フラグはオフ。
      一時は自身→位置
      「{音程¥(((一時¥0,1)-1)/14)}」をMML演奏。
  ノート[No]→マウス移動した時は~
    一時は自身→位置
    (((一時¥0,1)-1)/14)の白鍵変換,(((一時¥0,1)-1)/14)で鍵盤描画。
    もし、ノート移動フラグ=オンならば、
      もし、マウスY<=0ならば、
        もし、ノート位置\0,1=1でなければ、
          ノート位置¥0,1=(ノート位置¥0,1)-14
          ノート音程=ノート音程-1
      違えば、もし、マウスY>=12ならば、
        もし、ノート位置\0,1=155でなければ、
          ノート位置¥0,1=(ノート位置¥0,1)+14
          ノート音程=ノート音程+1
      もし、マウスX<=0ならば、
        もし、ノート位置\0,0=1でなければ、
          ノート位置¥0,0=(ノート位置¥0,0)-50
      違えば、もし、マウスX>48ならば、
        もし、ノート位置\0,0=151でなければ、
          ノート位置¥0,0=(ノート位置¥0,0)+50
      自身→位置はノート位置。
      自身→テキストは音程¥ノート音程
      自身→幅は48。
  No=No+1
#-----------------------------------------------------------
*MML作成
  一時は空。
  (No)回
    もし、ノート[回数-1]→テキスト=空でなければ、
      もし、一時¥((ノート[回数-1]→X)/50を切り下げ)=空ならば、
        一時¥((ノート[回数-1]→X)/50を切り下げ)=ノート[回数-1]→テキスト
      違えば、
        和音は一時¥((ノート[回数-1]→X)/50を切り下げ)
        もし、和音の1文字左部分=「{カッコ}」ならば、
          和音の1から1文字削除。和音の1文字右端削除
        和音=「{カッコ}{和音}{ノート[回数-1]→テキスト}{カッコ閉じ}」
        一時¥((ノート[回数-1]→X)/50を切り下げ)=和音。
  (一時の要素数)回
    もし、一時¥(回数-1)=空ならば、一時¥(回数-1)=「ッ」
  MMLは一時を「」で配列結合。
  確認エディタのテキストはMML。
#-----------------------------------------------------------


No. 13 の情報
アプリのバージョン : 1.02

なでしこ/ひまわりのバージョン : 1.563で確認済み

なでしこ(No.13)をダウンロード

このアプリのテキスト表示

このアプリの関連リンク1



アプリへのコメント

(編集パスワード送信)



ドラBOT
 なでしこ1 - 命令サンプル

12 :pepelon




’ドラクエ 10 オンライン のBOTです

’標準のスクリーンキーボードのみで動作します。

’画面の、戦闘と、フィールドを判定します。

’敵の追従も試しにつけてみました。

’以下プログラム内容




※※※積み木デザイナ:ここから※
※ 以下はデザインデータです。
※ コメントを削除しないようにしてください。
※ ---
※母艦とはフォーム##生成
母艦は「メインフォーム」
そのクライアントW=384#数値
そのクライアントH=472#数値
そのタイトル=「なでしこ」#文字列
※ ---
ボタン1とはボタン##生成
そのX=224#数値
そのY=8#数値
そのW=64#数値
そのH=32#数値
そのテキスト=「ボタン1」#文字列
※ ---
ラベル1とはラベル##生成
そのX=8#数値
そのY=88#数値
そのW=368#数値
そのH=376#数値
そのテキスト=「ラベル1」#文字列
※ ---
ボタン2とはボタン##生成
そのX=224#数値
そのY=48#数値
そのW=64#数値
そのH=32#数値
そのテキスト=「ボタン2」#文字列
※ ---
コンボ1とはコンボ##生成
そのX=80#数値
そのY=8#数値
そのW=136#数値
そのH=32#数値
そのテキスト=「コンボ1」#文字列
そのアイテム=「」#文字列
※ ---
コンボ2とはコンボ##生成
そのX=80#数値
そのY=48#数値
そのW=136#数値
そのH=32#数値
そのテキスト=「コンボ2」#文字列
そのアイテム=「」#文字列
※ ---
ラベル2とはラベル##生成
そのX=8#数値
そのY=8#数値
そのW=72#数値
そのH=32#数値
そのテキスト=「ラベル2」#文字列
※※※積み木デザイナ:ここまで※

初期設定を、呼ぶ。


ボタン1の、文字サイズは、文字大。
ボタン2の、文字サイズは、文字大。
コンボ1の、文字サイズは、文字大。
コンボ2の、文字サイズは、文字大。
ラベル1の、文字サイズは、文字大。
ラベル2の、文字サイズは、文字大。

ボタン1の、テキストは、「開始」。
ボタン2の、テキストは、「酒場」。
コンボ1の、アイテムは、「{タイム設定}」。
コンボ1の、テキストは、「ランダム」。
コンボ2の、アイテムは、「{行動選択}」。
コンボ2の、テキストは、「じゅもん」。
ラベル1の、テキストは、「」。
ラベル2の、テキストは、「距離」。

ボタン1のクリックした時は~メイン処理。
ボタン2のクリックした時は~酒場処理。


「{母艦のパス}再起動後処理.txt」が、存在。
もし、それ=はいならば
 ソフトキドウカクニンを、呼ぶ。
 ソフトマドチョウセイを、呼ぶ。
 5秒待つ。
 
 10回
  A=「アクティブ」。
  キークリを、呼ぶ。
  0.1秒待つ。
  A=「便利ボタン」。
  キークリを、呼ぶ。
  1秒待つ。
 「{母艦のパス}再起動後処理.txt」を、ファイル削除。
 5秒待つ。
 メイン処理を、呼ぶ。


A=「」。
「{母艦のパス}更新_自動操作.txt」が、存在。
もし、それ=はいならば
 Aに、「{母艦のパス}更新_自動操作.txt」を、読む。
 コンボ1=A¥0,0。
 コンボ2=A¥1,0。
 
 「{母艦のパス}更新_自動操作.txt」を、ファイル削除。
 ソフトキドウカクニンを、呼ぶ。
 ソフトマドチョウセイを、呼ぶ。
 5秒待つ。
 メイン処理を、呼ぶ。


ソフトキドウカクニンを、呼ぶ。
ソフトマドチョウセイを、呼ぶ。

待機。


●初期設定
 管理者権限取得。
 
 「{母艦のパス}設定ファイル.txt」が、存在。
 もし、それ=いいえならば
  「設定ファイルがありません。」と、言う。
  終わり。
 「{母艦のパス}設定ファイル.txt」を、Aに、読む。
 Aで、ナデシコする。
 
 敵位置要求=0。
 画面解析要求=0。
 状態=「初期化」。
 
 母艦のタイトルは、「{制御窓名} {状態} {敵位置要求} {画面解析要求}」。
 
 タイム設定=「1








10
ランダム」。
 
 行動選択=「じゅもん
特技
ランダム」。
 戻る。


●画像判定更新
 窓列挙。
 それの、2から、「{画像判定窓名}」を、表ピックアップ。
 もし、それ=「」ならば
  「0 0 0 0 0 0 0 0 0 0」の、「 」を、「{改行}」に、置換。
  画像データ=それ。
 違えば
  「{それ¥0,2}」の、「 」を、「{改行}」に、置換。
  画像データ=それ。
 
 戻る。


’キー位置設定=「キャンセル,ecs,20,645
’反時計回り,q,80,670
’前進,w,120,670
’時計回り,e,160,670
’オートラン,r,200,670
’左進,a,95,698
’後進,s,135,698
’右進,d,175,698
’便利ボタン,f,215,698
’歩く走る,z,110,725
’カメラリセット,x,150,725
’コマンド,v,230,725
’セリフ,b,270,725
’コミニケーション,n,310,725
’マップ,m,350,725」。


’ 『0、タイトル
’ 1戦闘判定=0。
’ 2Fメニュー=0。
’ 3戦闘メニュー=0。
’ 4HP残=0。
’ 5MP残=0。
’ 6Fメニュー番号=0。
’ 7戦闘メニュー番号=0。
’ 8キャラ方角=0。
’ 9壁方角=0。』



●メイン処理
 ソフトマドチョウセイを、呼ぶ。
 
 動作フラグ=0。
 3秒待つ。
 
 開始時間¥0=「{今日}」。
 開始時間¥1=「{今}」。
 
 今回周期=0。
 「{コンボ1}」で、条件分岐
  「ランダム」ならば
   今回周期=1。
  違えば
   全体周期=「{コンボ1}」。
 
 今回行動=0。
 「{コンボ2}」で、条件分岐
  「じゅもん」ならば
   全体行動=1。
  
  「特技」ならば
   全体行動=2。
  
  「ランダム」ならば
   今回行動=1。
  
  違えば
   今回行動=1。
 
 状態カウンタ=「」。
 (R=0)で、ループ。
  状態カウンタ¥20=状態カウンタ¥20+1。
  
  ’時々リセットする
  もし、状態カウンタ¥20>使用限界ならば
   「{母艦のパス}更新_自動操作.txt」に、「{コンボ1}{改行}{コンボ2}」を、保存。
   1秒待つ。
  ’時々ウインドウを調節する
  もし、状態カウンタ¥20%30=0ならば
   ソフトマドチョウセイAを、呼ぶ。
  
  ’プログラムの更新があるか
  更新処理を、呼ぶ。
  
  ’停止処理があるか
  テイシカクニンを、呼ぶ。
  
  ’ドラクエの窓をアクティブにする
  「{ドラクエ窓名}」を、窓アクティブ。
  
  ’ドラクエウインドウをクリックしてアクティブにする
  A=「アクティブ」。
  キークリを、呼ぶ。
  
  ’ラベルを更新する
  
  ラベル1の、テキストは、「ループ回:{状態カウンタ¥20}
戦闘回数:{状態カウンタ¥0}
平均戦闘:{平均戦闘間隔¥3}分/回
一次回数:{状態カウンタ¥0}
画解析1:{状態カウンタ¥1}
二次回数:{状態カウンタ¥2}
画解析2:{状態カウンタ¥3}
三次回数:{状態カウンタ¥4}
画解析3:{状態カウンタ¥5}
四次回数:{状態カウンタ¥6}
画解析4:{状態カウンタ¥7}
五次回段:{状態カウンタ¥8}
RMフィ:{状態カウンタ¥9}
戦闘待機:{状態カウンタ¥15}
戦闘RM:{状態カウンタ¥16}」。
  
  ’最初のキャンセル
  キャンセル操作を、呼ぶ。
  
  ’画像判定 ループの最初
  画像判定更新を、呼ぶ。
  
  ’周期ランダム作成
  もし、今回周期=1ならば
   100の、乱数。
   全体周期=それ/10。
  
  もし、画像データ¥1=0ならば
   画面解析要求=1。
   敵位置要求=0。
   状態=「探査中」。
   母艦のタイトルは、「{制御窓名} {状態} {画面解析要求} {敵位置要求}」。
   ’戦闘ではない
   ’調べるを、実行
   「{動作フラグ}」で、条件分岐。
    「0」ならば
     ’初回
     戦闘時間=0。
     状態カウンタ¥0=状態カウンタ¥0+1。
     動作フラグ=動作フラグ+1。
    
     平均戦闘間隔¥0=「{今日}」。
     平均戦闘間隔¥1=「{今}」。
     「{開始時間¥0}」と、「{平均戦闘間隔¥0}」の、日数差。
     平均戦闘間隔¥2=それ24*60*60。
     「{開始時間¥1}」と、「{平均戦闘間隔¥1}」の、秒差。
     平均戦闘間隔¥3=(それ+平均戦闘間隔¥2)/(状態カウンタ¥0)/60。
     「{平均戦闘間隔¥3}」を、2で、小数点四捨五入。
     平均戦闘間隔¥3=それ。
    
     宝箱処理を、呼ぶ。
    
     一次探査を、呼ぶ。
    「1」ならば
     ’少し近づいた
     状態カウンタ¥1=状態カウンタ¥1+1。
     動作フラグ=動作フラグ+1。
     画像探査を、呼ぶ。
    「2」ならば
     ’だいぶ近づいた1
     状態カウンタ¥2=状態カウンタ¥2+1。
     動作フラグ=動作フラグ+1。
     二次探査を、呼ぶ。
    「3」ならば
     ’だいぶ近づいた2
     状態カウンタ¥3=状態カウンタ¥3+1。
     動作フラグ=動作フラグ+1。
     画像探査を、呼ぶ。
    「4」ならば
     ’だいぶ近づいた3
     状態カウンタ¥4=状態カウンタ¥4+1。
     動作フラグ=動作フラグ+1。
     三次探査を、呼ぶ。
    「5」ならば
     ’だいぶ近づいた4
     状態カウンタ¥5=状態カウンタ¥5+1。
     動作フラグ=動作フラグ+1。
     画像探査を、呼ぶ。
    「6」ならば
     ’だいぶ近づいた5
     状態カウンタ¥6=状態カウンタ¥6+1。
     動作フラグ=動作フラグ+1。
     四次探査を、呼ぶ。
    「7」ならば
     ’だいぶ近づいた4
     状態カウンタ¥7=状態カウンタ¥7+1。
     動作フラグ=動作フラグ+1。
     画像探査を、呼ぶ。
    「8」ならば
     ’だいぶ近づいた5
     状態カウンタ¥8=状態カウンタ¥8+1。
     動作フラグ=動作フラグ+1。
     五次探査を、呼ぶ。
    違えば
     状態カウンタ¥9=状態カウンタ¥9+1。
     動作フラグ=1。
     ’会話してるかもしれないので
     5回
      キャンセル操作を、呼ぶ。
     ランダムウォークを、呼ぶ。
  
  違えば
   画面解析要求=1。
   敵位置要求=0。
   状態=「戦闘中」。
   母艦のタイトルは、「{制御窓名} {状態} {画面解析要求} {敵位置要求}」。
   ’戦闘中である
   ’決定ボタンを連打する。
   状態カウンタ¥15=状態カウンタ¥15+1。
   動作フラグ=0。
   
   戦闘開始を、呼ぶ。
   
   戦闘時間=戦闘時間+1。
   
   ’一回2.5秒なので、一回の戦闘は5分以内とする
   ’回数を変えたら ●戦闘開始 の秒数も考慮すること
   もし、戦闘時間>120ならば
    状態カウンタ¥16=状態カウンタ¥16+1。
    
    ’会話してるかもしれないので
    5回
     キャンセル操作を、呼ぶ。
    ランダムウォークを、呼ぶ。
  
 


●更新処理
 「{母艦のパス}更新_自動操作.txt」が、存在。
 もし、それ=はいならば
  5秒待つ。
  「{今日}_{今}」の、「/」を、「」に、置換。
  それの、「:」を、「」に、置換。
  「{母艦のパス}自動操作ログ\操作ログ{それ}.txt」に、「{ラベル1のテキスト}」を、保存。
  10秒待つ。
  「{母艦のパス}ドラクエ自動操作.nako」を、起動。
  終わり。
 戻る。
’ 『0、タイトル
’ 1戦闘判定=0。
’ 2Fメニュー=0。
’ 3戦闘メニュー=0。
’ 4HP残=0。
’ 5MP残=0。
’ 6Fメニュー番号=0。
’ 7戦闘メニュー番号=0。
’ 8キャラ方角=0。
’ 9壁方角=0。』


●戦闘開始
 もし、画像データ¥3=1ならば
  もし、画像データ¥5=1ならば
   0.5秒待つ。
   ’今回行動を、言う。
   ’キャンセル操作を、呼ぶ。
   もし、今回行動=1ならば
    2の乱数。
    全体行動=それ+1。
   
   ’特技を使う
   「{全体行動}」回
    A=「下」。
    キークリを、呼ぶ。
    0.3秒待つ。
    ’決定ボタンを押す
   
   3回
    A=「便利ボタン」。
    キークリを、呼ぶ。
    0.2秒待つ。
   3秒待つ。
  違えば
   3回
    A=「便利ボタン」。
    キークリを、呼ぶ。
    0.2秒待つ。
   3秒待つ。
 違えば
  1秒待つ。
 戻る。


●しらべる探索
 A=「コマンド」。
 キークリを、呼ぶ。
 0.5秒待つ。
 A=「右」。
 キークリを、呼ぶ。
 0.15秒待つ。
 A=「下」。
 キークリを、呼ぶ。
 0.15秒待つ。
 A=「下」。
 キークリを、呼ぶ。
 0.15秒待つ。
 
 2回
  A=「便利ボタン」。
  キークリを、呼ぶ。
  0.3秒待つ。
 
 3回
  A=「キャンセル」。
  キークリを、呼ぶ。
  0.3秒待つ。
 
 戻る。


●宝箱処理
 4回
  20回
   A=「前進」。
   キークリを、呼ぶ。
   0.01秒待つ。
  5回
   A=「便利ボタン」。
   キークリを、呼ぶ。
   0.2秒待つ。
 戻る。


●画像探査
 しらべる探索を、呼ぶ。
 
 ’一旦キャラを向ける
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 ’カメラをリセットする
 A=「カメラリセット」。
 キークリを、呼ぶ。
 1秒待つ。
 
 ’画像解析要求を、する
 画面解析要求=1。
 敵位置要求=1。
 状態=「画像探査中」。
 母艦のタイトルは、「{制御窓名} {状態} {画面解析要求} {敵位置要求}」。
 A=「」。
 ヨコMAX=0。
 タテMAX=0。
 10回
  ’解析完了まで最大10秒待つ。
  窓列挙。
  それの、2から、「{画像敵位置判定窓名}」を、表ピックアップ。
  (それ¥0)の、「 」を、「{改行}」に、置換。
  A=それ。
  もし、それ¥4=「完了」ならば
   ヨコMAX=それ¥5。
   タテMAX=それ¥6。
   抜ける。
  違えば
   1秒待つ。
 
 ’途中戦闘になったか確認
 画像判定更新を、呼ぶ。
 もし、画像データ¥1=1ならば
  キャンセル操作を、呼ぶ。
  A=「戦闘」。
  ’「{ヨコMAX} {タテMAX}」を、言う。
  戻る。
 
 ’画像解析要求を、やめる
 画面解析要求=1。
 敵位置要求=0。
 状態=「画像探査中」。
 母艦のタイトルは、「{制御窓名} {状態} {画面解析要求} {敵位置要求}」。
 
 A=ヨコMAX+タテMAX。
 もし、A=0ならば
  ’解析要求失敗
  戻る。
 違えば
  ’角度を割り出す
  ヨコMAX=403-ヨコMAX。
  タテMAX=タテMAX。
  
  角度=0。
  距離=タテMAX/80。
  
  ARCTAN(タテMAX/ヨコMAX)。
  それを、度変換。
  (それ/3/2)の、整数部分
  角度=それ。
  
  もし、角度<0ならば
   「{角度}」回
    A=「時計回り」。
    キークリを、呼ぶ。
    0.01秒待つ。
    ’「{ヨコMAX} {タテMAX} {角度} {距離}」を、言う。
  違えば
   角度の、絶対値。
   「{それ}」回
    A=「反時計回り」。
    キークリを、呼ぶ。
    0.01秒待つ。
    ’「{ヨコMAX} {タテMAX} {角度} {距離}」を、言う。
  
  ’直線で進む
  A=「オートラン」。
  キークリを、呼ぶ。
  
  窓列挙。
  それの、2から、「ドラゴンクエストX 」を、表ピックアップ。
  (それ¥0,0)の、窓ハンドルサイズ取得。
  A=ヨコMAX+(それ¥0,0)。
  B=タテMAX+(それ¥0,1)。
  A,Bへマウス移動。
  「{距離}」秒待つ。
 戻る。


●一次探査
 しらべる探索を、呼ぶ。
 ’1回目なので直進で敵との距離を詰める
 ’一旦キャラを向ける
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 ’直線で進む
 A=「オートラン」。
 キークリを、呼ぶ。
 「{全体周期*0.5}」秒待つ。
 
 戻る。


●二次探査
 しらべる探索を、呼ぶ。
 ’2回目で更に詰める
 ’一旦キャラを向ける
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 ’直線で進む
 A=「オートラン」。
 キークリを、呼ぶ。
 「{全体周期*0.8}」秒待つ。
 
 戻る。


●三次探査
 しらべる探索を、呼ぶ。
 ’3回目で更に詰める
 ’一旦キャラを向ける
 
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 10回
  A=「時計回り」。
  キークリを、呼ぶ。
  0.01秒待つ。
 
 ’直線で進む
 A=「オートラン」。
 キークリを、呼ぶ。
 「{全体周期*0.5}」秒待つ。
 
 戻る。


●四次探査
 しらべる探索を、呼ぶ。
 ’3回目で更に詰める
 ’一旦キャラを向ける
 
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 10回
  A=「時計回り」。
  キークリを、呼ぶ。
  0.01秒待つ。
 
 ’直線で進む
 A=「オートラン」。
 キークリを、呼ぶ。
 「{全体周期*0.3}」秒待つ。
 
 戻る。


●五次探査
 しらべる探索を、呼ぶ。
 ’3回目なのでぐるぐる探査
 ’合間を詰める
 A=「前進」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 ’直線で進む
 A=「オートラン」。
 キークリを、呼ぶ。
 0.1秒待つ。
 
 ’45度回転*8回=360度
 
 2の、乱数。
 RAN¥0=それ。
 
 10の乱数。
 RAN¥1=それ。
 
 もし、RAN¥0=1ならば
  8回
   18回
    A=「時計回り」。
    キークリを、呼ぶ。
    「{(RAN¥1)/50}」秒待つ。
   ’途中戦闘になったか確認
   画像判定更新を、呼ぶ。
   もし、画像データ¥1=1ならば
    キャンセル操作を、呼ぶ。
    A=「戦闘」。
    戻る。
 違えば
  8回
   18回
    A=「時計回り」。
    キークリを、呼ぶ。
    「{(RAN¥1)/50}」秒待つ。
   ’途中戦闘になったか確認
   画像判定更新を、呼ぶ。
   もし、画像データ¥1=1ならば
    キャンセル操作を、呼ぶ。
    A=「戦闘」。
    戻る。
 戻る。


●ランダムウォーク
 キャンセル操作を、呼ぶ。
 
 A=「オートラン」。
 キークリを、呼ぶ。
 0.2秒待つ。
 
 ’右回り、左回り
 2の乱数。
 RAN¥0=それ。
 
 ’回転回数 何回回るか
 50の乱数。
 RAN¥1=それ。
 
 ’周りのキツさ 短いほうがきつい
 10の乱数。
 RAN¥2=それ。
 
 もし、動作フラグ>0ならば
  ’戦闘中でなないので、
  ’直線あり 一旦直進させる
  30の乱数。
  「{それ/10}」秒待つ。
 
 もし、RAN¥0=0ならば
  ’右回り
  「{RAN¥1}」回
   A=「時計回り」。
   キークリを、呼ぶ。
   「{(RAN¥2)/100}」秒待つ。
 違えば
  ’左回り
  「{RAN¥1}」回
   A=「反時計回り」。
   キークリを、呼ぶ。
   「{(RAN¥2)/100}」秒待つ。
 戻る。


●キャンセル操作
 5回
  A=「キャンセル」。
  キークリを、呼ぶ。
  0.1秒待つ。
 戻る。


●ソフトキドウカクニン
 プロセス列挙。
 それの、0から、「{ドラクエP名}」を、表完全一致ピックアップ。
 もし、それ=「」ならば
  「ドラクエが起動していない、ログインまで進めてください。」と、言う。
  タイキショリを、呼ぶ。
 
 プロセス列挙。
 それの、0から、「{キーボードP名}」を、表完全一致ピックアップ。
 もし、それ=「」ならば
  「{母艦のパス}On-ScreenKeyboard.lnk」を、管理者権限実行。
  A=0。
  (R=0)で、ループ。
   プロセス列挙。
   それの、0から、「{キーボードP名}」を、表完全一致ピックアップ。
   もし、それ<>「」ならば
    3秒待つ。
    抜ける。
   1秒待つ。
   A=A+1。
   もし、A=10ならば
    「{キーボード窓名}が起動できませんでした」と、言う。
    タイキショリを、呼ぶ。
 
 窓列挙。
 それの、2から、「{画像判定窓名}」を、表ピックアップ。
 もし、それ=「」ならば
  「{母艦のパス}{画像判定P名}」を、起動。
  A=0。
  (R=0)で、ループ。
   窓列挙。
   それの、2から、「{画像判定窓名}」を、表ピックアップ。
   もし、それ<>「」ならば
    3秒待つ。
    抜ける。
   1秒待つ。
   A=A+1。
   もし、A=10ならば
    「{画像判定窓名}が起動できませんでした」と、言う。
    タイキショリを、呼ぶ。
 
 窓列挙。
 それの、2から、「{画像敵位置判定窓名}」を、表ピックアップ。
 もし、それ=「」ならば
  「{母艦のパス}{画像敵位置判定P名}」を、起動。
  A=0。
  (R=0)で、ループ。
   窓列挙。
   それの、2から、「{画像敵位置判定窓名}」を、表ピックアップ。
   もし、それ<>「」ならば
    3秒待つ。
    抜ける。
   1秒待つ。
   A=A+1。
   もし、A=10ならば
    「{画像敵位置判定窓名}が起動できませんでした」と、言う。
    タイキショリを、呼ぶ。
 
 戻る。


●ソフトマドチョウセイ
 窓列挙。
 それの、2から、「{画像判定窓名}」を、表ピックアップ。
 「{それ¥0,0}」の、窓ハンドルサイズ取得。
 もし、それ¥0,0<0ならば
  「画像判定が表示されていません1」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,1<-15ならば
  「画像判定が表示されていません2」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,2<0ならば
  「画像判定が表示されていません3」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,3<0ならば
  「画像判定が表示されていません4」と、言う。
  タイキショリを、呼ぶ。
 
 窓列挙。
 それの、2から、「{画像敵位置判定窓名}」を、表ピックアップ。
 「{それ¥0,0}」の、窓ハンドルサイズ取得。
 もし、それ¥0,0<0ならば
  「敵位置判定が表示されていません1」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,1<-15ならば
  「敵位置判定が表示されていません2」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,2<0ならば
  「敵位置判定が表示されていません3」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,3<0ならば
  「敵位置判定が表示されていません4」と、言う。
  タイキショリを、呼ぶ。
 
 窓列挙。
 それの、2から、「{キーボード窓名}」を、表ピックアップ。
 「{それ¥0,0}」の、窓ハンドルサイズ取得。
 もし、それ¥0,0<0ならば
  「キーボードが表示されていません」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,1<0ならば
  「キーボードが表示されていません」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,2<0ならば
  「キーボードが表示されていません」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,3<0ならば
  「キーボードが表示されていません」と、言う。
  タイキショリを、呼ぶ。
 
 窓列挙。
 それの、2から、「{ドラクエ窓名}」を、表ピックアップ。
 「{それ¥0,0}」の、窓ハンドルサイズ取得。
 もし、それ¥0,0<0ならば
  「ドラクエが表示されていません1」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,1<-15ならば
  「ドラクエが表示されていません2」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,2<0ならば
  「ドラクエが表示されていません3」と、言う。
  タイキショリを、呼ぶ。
 もし、それ¥0,3<0ならば
  「ドラクエが表示されていません4」と、言う。
  タイキショリを、呼ぶ。
 
 ソフトマドチョウセイAを、呼ぶ。
 戻る。


●ソフトマドチョウセイA
 窓列挙。
 それの、2から、「{キーボード窓名}」を、表ピックアップ。
 「{それ¥0,0}」に、「0,612,793,773」を、窓ハンドルサイズ設定。
 「{キーボード窓名}」を、窓アクティブ。
 ’「{それ¥0,0}」を、0,0へ、窓ハンドル位置移動。
 
 窓列挙。
 それの、2から、「{制御窓名}」を、表ピックアップ。
 「{それ¥0,0}」に、「808,0,1280,612」を、窓ハンドルサイズ設定。
 「{制御窓名}」を、窓アクティブ。
 ’「{それ¥0,0}」を、0,0へ、窓ハンドル位置移動。
 
 窓列挙。
 それの、2から、「{画像判定窓名}」を、表ピックアップ。
 「{画像判定窓名}」を、窓アクティブ。
 「{それ¥0,0}」に、「790,612,1280,662」を、窓ハンドルサイズ設定。
 
 窓列挙。
 それの、2から、「{画像敵位置判定窓名}」を、表ピックアップ。
 「{画像判定窓名}」を、窓アクティブ。
 「{それ¥0,0}」に、「790,662,1280,712」を、窓ハンドルサイズ設定。
 
 窓列挙。
 それの、2から、「{ドラクエ窓名}」を、表ピックアップ。
 「{それ¥0,0}」に、「0,-15,808,612」を、窓ハンドルサイズ設定。
 ’「{それ¥0,0}」を、0,0へ、窓ハンドル位置移動。
 「{ドラクエ窓名}」を、窓最前面。
 
 戻る。


●キークリ
 プロセス列挙。
 それの、0から、「{停止P名}」を、表ピックアップ。
 もし、それ<>「」ならば
  「タスクマネージャーが起動しています{待機}処理を停止します」と、言う。
  タイキショリを、呼ぶ。
 
 「{ドラクエ窓名}」を、窓最前面。
 ’キー位置設定の、0から、「試」を、表完全一致ピックアップ。
 ’(それ¥0,2),(それ¥0,3)へマウス移動。
 ’マウスクリック。
 
 キー位置設定の、0から、「{A}」を、表完全一致ピックアップ。
 A=それ。
 もし、A=「」ならば
  「キーが設定されていない」と、言う。
  タイキショリを、呼ぶ。
 
 (A¥0,2),(A¥0,3)へマウス移動
 マウスクリック。
 戻る。


●テイシカクニン
 プロセス列挙。
 それの、0から、「{停止P名}」を、表ピックアップ。
 もし、それ<>「」ならば
  「{今日}_{今}」の、「/」を、「」に、置換。
  それの、「:」を、「」に、置換。
  「{母艦のパス}自動操作ログ\操作ログ{それ}.txt」に、「{状態カウンタ}」を、保存。
  キャンセル操作を、呼ぶ。
  「{ドラクエ窓名}」を、窓最前面解除。
  「タスクマネージャーが起動しています{待機}処理を停止します」と、言う。
 戻る。


●タイキショリ
 「{ドラクエ窓名}」を、窓最前面解除。
 待機。



’キー位置設定=「キャンセル,ecs,20,645
’反時計回り,q,80,670
’前進,w,120,670
’時計回り,e,160,670
’オートラン,r,200,670
’左進,a,95,698
’後進,s,135,698
’右進,d,175,698
’便利ボタン,f,215,698
’歩く走る,z,110,725
’カメラリセット,x,150,725
’コマンド,v,230,725
’セリフ,b,270,725
’コミニケーション,n,310,725
’マップ,m,350,725
’上,up,590,725
’右,right,626,754
’左,left,551,754
’下,down,588,754
’試,1,100,645
’アクティブ,0,40,0」。


’ 『0、タイトル
’ 1戦闘判定=0。
’ 2Fメニュー=0。
’ 3戦闘メニュー=0。
’ 4HP残=0。
’ 5MP残=0。
’ 6Fメニュー番号=0。
’ 7戦闘メニュー番号=0。
’ 8キャラ方角=0。
’ 9壁方角=0。』

●酒場処理
 A=「コマンド」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 A=「下」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 A=「便利ボタン」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 A=「下」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 A=「便利ボタン」。
 キークリを、呼ぶ。
 0.5秒待つ。
 
 20秒待つ。
 
 
 


●メニューコマンド満タン
 
 
 
 
 


●メニューコマンドゲーム終了
 
 
 
 
 


●戦闘コマンド魔法1
 
 
 
 


●戦闘コマンド魔法2
 
 
 
 


●戦闘コマンド魔法3
 
 
 
 


●戦闘コマンド魔法4
 
 
 
 


●戦闘コマンド特技1
 
 
 
 


●戦闘コマンド特技2
 
 
 
 


●戦闘コマンド特技3
 
 
 
 


●戦闘コマンド特技4
 
 
 
 


●マップ位置判定
 ’行ける空間を、判定する
 ’自分の向いてる方角を判定する。
 
 
 
 
 
 

 

No. 12 の情報
なでしこ/ひまわりのバージョン : 1.561

対応OS :
Windows10 / Windows7 /

権利の許可 :
A.連絡不要で、すべて自由に許可(原作者を表示なしで改変/営利可能)


なでしこ(No.12)をダウンロード

このアプリのテキスト表示

このアプリの関連リンク1



アプリへのコメント

(編集パスワード送信)



簡易不要ファイル削除
 なでしこ1 - その他

11 :hanatai001




/*
ファイル名:PC_cleaner
名前:hantai001
mail:hanatai0815あっとまーくgmail.com
権利とか:↑メールに連絡してください。


このソフトの使い方
①このソフトと同じ層に「ファイル設定.ini」を作り、削除したい拡張子を;で区切ります。
例):*.lwi;Thumbs.db;*.bak
 ↑だと『.lwi』、『Thumbs.db』、『.bak』ファイルの削除が可能です。
②ソフトを起動します。
③フォルダ選択が行われるので、クリーンしたいフォルダを選択して下さい。
④不要ファイルが存在するかを検索します。しばらくお待ちください。
⑤メモ帳に削除するファイルが書き込まれるので、必要なファイルがあれば消して[決定]を押してください。
⑥終了

-どうしても分からない、使えないという方はTwitter:yumaru_sまでお願いします。-
*/

#ソースここから
!母艦設計=「母艦の可視はオフ」
母艦=「PC_cleaner」
母艦を中央移動。
母艦の可視はオン
もし(「{母艦パス}ファイル設定.ini」が存在する)ならば、Aに「{母艦パス}ファイル設定.ini」を読む。#4
ゴミ拡張子=A
フォルダ選択して対象DIRに代入。#2
対象DIR&ゴミ拡張子の全ファイル列挙して、対象ファイルに代入。#3
「以下のファイルを削除します。
{対象ファイル}」をメモ記入。#4
もし(それ=空)ならば、終わる。#5
対象ファイルを反復 #6
  母艦のタイトル=対象。#7
  対象のファイル削除。#8
「削除完了しました」と言う。#9
終わり。#10 
#ここまで



No. 11 の情報
アプリのバージョン : 1.0

なでしこ/ひまわりのバージョン : 1.562

対応OS :
Windows10 / Windows8 / Windows7 /

権利の許可 :
11.連絡許可で、原作者(作品タイトル・作者名・URL)を表示させれば非営利のみ可能/改変は原作者を表示させれば可能


なでしこ(No.11)をダウンロード

このアプリのテキスト表示



アプリへのコメント

(編集パスワード送信)



なこみくじ
 なでしこ1 - ゲーム

10 :雪乃☆雫




 新年のご挨拶代わりに、おみくじです。
 乱数ではなく、「今」から風水的な吉凶数を算出しています。
 「今」を「今日」に変えれば、誰が引いても変わらない「今日の運勢」になります。
 また、電話番号や暗証番号、部屋番など、身近な数字の吉凶も見ることができます。
 まっ、遊びですけどw 吉凶数の計算も、簡易的なものです。
 いちおう、吉凶数は二十年ごとに変動があるため、有効期限は2024年2月3日まで。

No. 10 の情報
アプリのバージョン : 1.00

なでしこ/ひまわりのバージョン : 1.562

なでしこ(No.10)をダウンロード

このアプリのテキスト表示

このアプリの関連リンク1



アプリへのコメント

(編集パスワード送信)



サクラMMLエディタ

No.9

準備中

(編集パスワード送信)




RSS


www.eznavi.net