ナビ 制作 公式 ヘルプ


 NADE BBS

 トップ 最新 新規書込 検索

new2017-08-22 19:29:48 -火 曜-

276 : Re:2種類の配列を縦覧して項目を付加したい。スピードも欲張りたい。 - ひろ さん


お知恵を貸してください。
事務業務が中心で、エクセルと連動したデータの抜出・整理に使用しています。

共通項のある2種類の配列があり、
X=「1,a{~}2,b{~}3,c{~}4,d{~}5,e」
Y=「2,丑{~}4,卯{~}6,巳」
このとき、共通する0列を検索値として、マッチするものがあった場合、Yの要素をXに移す命令を組みました。
X’=「1,a{~}2,b,丑{~}3,c{~}4,d,卯{~}5,e」

●縦覧付加(X,A,Y,B,C,D)
 #配列XのA列と配列YのB列を照合、一致すればXのC列にYのD列を付加 
 #ここから 

|ROWを0から(Xの行数-1)まで繰り返す 
||検索値=X[ROW,A] 
||ROW2を0から(Yの行数-1)まで繰り返す 
|||もしY[ROW2,B]=検索値ならば 
||||X[ROW,C]=Y[ROW2,D] 
||||続ける 

#ここまで
#引数が多いと助詞のつけかたがわからず、引数の定義が適当です

動くには動くのですが、素人目に見ても「総当たり」の作業なので、
配列が700行とかあると処理に時間がかかります。
PCを再起動した直後で、ほかのプログラムを起動していなくても4-5分かかります。

ここで手練れの皆様に聞くと全然違うプログラムになりそうですが、
処理速度も見込めるような記述があれば参考にさせてください。

基本的に「オフでやる」「エクセルに頼らずできることは内部メモリを利用して行う」くらいしか、
処理速度を上げる知識を持ち合わせていません。
そのあたりについてもご指導いただけると幸いです。


こんにちは
最善の方法ではないかもしれませんが、こうゆうケースに私が行っている方法です。

X=「1,a{~}2,b{~}3,c{~}4,d{~}5,e」をCSV取得
Y=「2,丑{~}4,卯{~}6,巳」をCSV取得
aで0から(Xの表行数-1)まで繰り返す
  Yの0でX【a,0】を表検索
  もし(それ<>-1)ならば
    X【a,2】=Y【それ,1】

(編集パスワード送信)

子記事

親記事 (No.275)
返信した記事(元) (No.275)

この内容(No.276)に返信

この内容(No.276)をダウンロード

この内容(No.276)のテキスト表示


new2017-08-22 18:09:26 -火 曜-

275 : 2種類の配列を縦覧して項目を付加したい。スピードも欲張りたい。 - ぎん さん


お知恵を貸してください。
事務業務が中心で、エクセルと連動したデータの抜出・整理に使用しています。

共通項のある2種類の配列があり、
X=「1,a{~}2,b{~}3,c{~}4,d{~}5,e」
Y=「2,丑{~}4,卯{~}6,巳」
このとき、共通する0列を検索値として、マッチするものがあった場合、Yの要素をXに移す命令を組みました。
X’=「1,a{~}2,b,丑{~}3,c{~}4,d,卯{~}5,e」

●縦覧付加(X,A,Y,B,C,D)
 #配列XのA列と配列YのB列を照合、一致すればXのC列にYのD列を付加 
 #ここから 

|ROWを0から(Xの行数-1)まで繰り返す 
||検索値=X[ROW,A] 
||ROW2を0から(Yの行数-1)まで繰り返す 
|||もしY[ROW2,B]=検索値ならば 
||||X[ROW,C]=Y[ROW2,D] 
||||続ける 

#ここまで
#引数が多いと助詞のつけかたがわからず、引数の定義が適当です

動くには動くのですが、素人目に見ても「総当たり」の作業なので、
配列が700行とかあると処理に時間がかかります。
PCを再起動した直後で、ほかのプログラムを起動していなくても4-5分かかります。

ここで手練れの皆様に聞くと全然違うプログラムになりそうですが、
処理速度も見込めるような記述があれば参考にさせてください。

基本的に「オフでやる」「エクセルに頼らずできることは内部メモリを利用して行う」くらいしか、
処理速度を上げる知識を持ち合わせていません。
そのあたりについてもご指導いただけると幸いです。


(編集パスワード送信)

親記事

この内容(No.275)に返信

この内容(No.275)をダウンロード

この内容(No.275)のテキスト表示

子記事

276 Re:2種類の配列を縦覧して項目を付加したい。スピードも欲張りたい。 (17-08-22) new

new2017-08-22 11:21:41 -火 曜-

274 : Filemakerプラグインからのメール送信について - yummy さん


Filemakerプラグインのなでしこで、うまくメール送信が出来ません。

3台のマシンをサーバを介してファイル共有し、利用していますが、3台中1台のFilemaker Advanced 15からは正常にメール送信出来るのに、Filemaker Pro 15の2台からはメール送信が出来ず、何のエラーも出ません。なでしこ自体は動いており、メール送信のあとのコマンドは実行されます。

ちなみにプラグインでなく、通常のなでしこに同様のコマンドを実行させたところ、普通にメール送信できました。

プラグインのバグでしょうか??



ちなみに実行コマンドは以下の通りです。どうぞよろしくお願い致します。



nako("
メールホストは、「********」¶
メールIDは、「********」¶
メールパスワードは、「********」¶
メールオプションは、「LOGIN」# 認証方式「LOGIN/PLAIN/SSL」を。¶
メールポートは、*****¶
メール差出人は「********」¶
メールBCCは「********」¶
メール宛先は「"
&  
受注テーブル::メールアドレス_メイン_
&
"」¶
メール件名は「"& 受注テーブル::メール件名 & "」¶
メール本文は「"&
受注テーブル::作成メール本文
& "」¶

メール添付ファイルは「"&
受注テーブル::複数ファイルアドレス
&"」¶
メール送信。¶
「送信が終わりました」と言う。¶
"
 )

(編集パスワード送信)

親記事

この内容(No.274)に返信

この内容(No.274)をダウンロード

この内容(No.274)のテキスト表示


2017-08-18 15:52:16 -金 曜-

273 : Re:エクセルがうまく 立ち上がりません。 - じゃがいも さん


エクセル起動。
#デスクトップ&「Book1.xls」をエクセル開く。
「{デスクトップ}Book1.xls」をエクセル開く。
「おわります」と言う。
エクセル終了。

#-------------------------------

[エラー] com.nadesi.exe.nakopad.temp.nako1.bak(3): 関数『エクセル開』の実行中にエラーが起きました。'C:\Users\666\Desktop\Book1.xls' が見つかりません。ファイル名およびファイルの保存場所が正しいかどうかを確認してください。

最近使用したファイルの一覧からファイルを開こうとしている場合は、そのファイルの名前が変更されていないこと、移動または削除されていないことを確認してください。(関数)
 EXCEL が立ち上がりますが
そのあとが 続きません

エラ-がでます。

わかりません

ありがどうございます あいかわらすです。次からつぎへと わからないことが でてきます。
ノ-トン の削除は たくさん でてまして おてあげです。わけわかりません。
ネット につながずにやってみようかと 思っています。
デラックス版が正しく インスト-ル されたか 確かめる方法 ツ-ル ありましたら 教えてください。


(編集パスワード送信)

子記事

親記事 (No.261)
返信した記事(元) (No.261)

この内容(No.273)に返信

この内容(No.273)をダウンロード

この内容(No.273)のテキスト表示


2017-08-18 09:39:12 -金 曜-

272 : いろいろの回答です。 - choco さん



セキュリティ ソフトのws.Reputation の 削除は  セキュリティ ソフトの 削除 から 復元を クリックで 対処しました。
⇒ノートンを利用されているのですね。セキュリティソフトの設定で「なでしこ」を除外すれば良いと思います。

それから 意味が 分からなかったのが ファイルメ-カ- プロ 15をあらかじめ ご用意 くださいと とう 言葉の 意味で
意味が 分からないので スル- しておりましたかが プラグイン ソフトをダウンロ-ド インスト-ル するには 必要 見たいですが
35000円 を ご用意 して このソフトを 買ってくださいということだったのでしょうか。
ファイルメ-カ- プロ 15を ご用意 できない方は excelを なでしこで 心行くまで 使えませんと いうことなんでしょうか
⇒ファイルメーカーのプラグインを利用しないのであれば、何も必要ありません。なでしこ本体だけでEXCELの操作は可能です。



(編集パスワード送信)

子記事

親記事 (No.261)
返信した記事(元) (No.271)

この内容(No.272)に返信

この内容(No.272)をダウンロード

この内容(No.272)のテキスト表示


最新に戻る < < < > > > 次へ



RSS


www.eznavi.net