ナビ 制作 公式 ヘルプ


 NADE BBS

 トップ 最新 新規書込 検索

2017-04-09 12:01:36 -日 曜-

165 : csvデータをLuaとなでしこで得て返す処理 - こんにちわ さん


大量のcvsデータを比較するプログラムを制作したのですが
余りにも
なでしこだけては処理に時間が掛かり過ぎるので

●使い条件分岐構文~もし~
●指定した回数だけプログラムを繰り返し~回

の部分をLuaでサブルーチンで対応しようと思い
試行錯誤しています

まず
Luaが配列に対応していない事
なので どの様に
なでしこのcsvデータをLuaの変数の値を得て返すのかが
よくわかりません

すいません 
サンプルを例として ご教授よろしくお願いします





#---サンプル はじめ
#-(なでしこで入力したcvsデータ)
AB配数【01,01】=123
AB配数【01,02】=12
AB配数【01,03】=125
AB配数【01,04】=126
AB配数【02,01】=00
AB配数【02,02】=00
AB配数【02,03】=00
AB配数【02,04】=00


#-なでしこからLuaへ
#-cvsデータの引継ぎが分からない


#-----ここから Luaで高速化したい↓
#-(Luaでcsvデータを処理)
aa=1
04回
  もし AB配数【01,aa】=12 ならば
    回数&「番目にありました」を表示
    AB配数【02,aa】=回数
  aa=aa+1
#-----ここまで↑


#-Luaからなでしこへ
#-cvsデータの引継ぎが分からない


#-(なでしこで処理されたcsvデータを表示)
AB配数を表示
#---サンプル おわり

(編集パスワード送信)

親記事

この内容(No.165)に返信

この内容(No.165)をダウンロード

この内容(No.165)のテキスト表示

子記事

168 Re:Re:csvデータをLuaとなでしこで得て返す処理 (17-04-19)
167 Re:csvデータをLuaとなでしこで得て返す処理 (17-04-19)



RSS


www.eznavi.net