日本語プログラミング言語なでしこの公式掲示板

なでしこ の 掲示板

トップ 最新 新規 検索 公式

2018-03-13 19:25:54 -火 曜-

424 : 指定された範囲の文字数を数える方法 - kagawa sinzi さん


いつもお世話になっております。
 ある指定された場所の文字数の数え方を教えてください。
  
 範囲切り取りで「AM="」から「"」までの文字数を数えることに
  成功しましたと思いましたが、同時に「AM="6C6EC0"」まで切り取られてしまう
  ことに気づきました。切り取らず純粋に指定された範囲まで文字数
  だけ数える方法があれば教えてください。

下は自分が作成したプログラムですが範囲切り取りだとその場所も一緒に切り取られてしまいます。

A=『あああAM="6C6EC0"いいい』

Aの「AM="」から「"」まで範囲切り取る。
切り取った部分=それ

C=「{切り取った部分}」

  もし Cの文字数が「6」ならば
   「正解6文字」と言う
  違えば
   「6文字ではありません」と言う 

😄宜しくお願い申し上げます。


(編集パスワード送信)

親記事

この内容(No.424)に返信

この内容(No.424)をダウンロード

この内容(No.424)のテキスト表示

子記事

426 Re:指定された範囲の文字数を数える方法 (18-03-13)
425 Re:指定された範囲の文字数を数える方法 (18-03-13)




www.eznavi.net