日本語プログラミング言語なでしこ公式のアプリ - サンプルプログラム掲示板

なでしこ の アプリ-サンプル

トップ 登録 検索 ヘルプ
😍 😄 😌 😓
😄😍😍

Windowsスポットライト保存
 なでしこ1 - カテゴリ無し

66 :mskzさん




Windowsスポットライトの画像をリネームしてマイピクチャのフォルダに保存します

なでしこソフトの画像サイズ取得を使用しています
http://nadesiko.soft.at-ninja.jp/lib/getimgsize.html

初心者なので無駄な部分があるかもしれません



# --- 母艦
母艦の可視はオフ。

# --- フォルダの設定
コピー元=「{個人設定フォルダ}Packages\Microsoft.Windows.ContentDeliveryManager_cw5n1h2txyewy\LocalState\Assets」 
コピー先=「{マイピクチャー}temp\」 
移動先=「{マイピクチャー}wall\」

# --- コピー元列挙と確認
「{コピー元}」の全ファイル列挙して一覧に代入。
「Windowsスポットライトのファイルを{改行}{移動先}にコピーします。{改行}」と二択。
もし、それがいいえならば、終わり。

# --- コピー処理
一覧を反復
バイト=対象のファイルサイズ。
キロ=バイト÷1024
もし、キロが250以上ならば、
対象からファイル名抽出して60文字右端削除してさふぃに代入。
   対象のファイル日付を9文字右端削除。
   それを「/」で区切る。年はそれ[0]。月はそれ[1]。日はそれ[2]。
   保存名=「{コピー先}{年}{月}{日}-{さふぃ}.jpg」。
   # -- コピー処理
   母艦のタイトルは対象。
   対象を保存名にファイルコピー。

# --- getimgsize.nako 取り込み
!「getimgsize.nako」を取り込む

# --- コピー先列挙
「{コピー先}」の全ファイル列挙して先一覧に代入。

# --- 比較と削除
先一覧を反復
対象の画像サイズ取得
もし、それ[0]がそれ[1]以下ならば、
対象をファイル削除

# --- コピー先列挙
「{コピー先}」の全ファイル列挙して先一覧に代入。

# --- 移動処理
先一覧を反復
  対象からファイル名抽出してファイル名に代入。
  保存名=「{移動先}{ファイル名}」。

  # -- コピー処理
  母艦のタイトルは対象。
  対象を保存名にファイル移動。

# --- 完了通知
母艦のタイトルは「作業終了」。
「{先一覧} を{改行}{改行}{移動先}にコピーしました。」と言う。
「{移動先}」を起動
終わり。

No. 66 の情報

なでしこ(No.66)をダウンロード

このアプリのテキスト表示






(編集パスワード送信)





www.eznavi.net

😄😍😍...🔻
😍2😄1