日本語プログラミング言語なでしこの公式掲示板

なでしこ の 掲示板

トップ 最新 新規 検索 公式

2020-01-15 18:38:27 -水 曜-

798 : コマンド実行命令で「qwinsta」がエラーになります。 - まるぼうず さん


※カテゴリで「なでしこ1」「なでしこ3」とは?

お世話のなります。

「qwinsta」と「logoff」のコマンドを使用してサーバーにログインしたユーザーを遠隔からログオフするプログラムを作成しました。
Windows7から実行すると問題なくログオフできるのですが、Windows10から実行するとエラーになります。

[エラー] 関数『コマンド実行』の実行中にエラーが起きました。『qwinsta XXXXXXX /server:YYYYYYYY』を実行できません。理由は、2。(関数)

管理者権限で実行してもダメでした。

ご指導
よろしくお願いいたします。

(編集パスワード送信)

親記事

この内容(No.798)に返信

この内容(No.798)をダウンロード

この内容(No.798)のテキスト表示


2020-01-14 01:43:58 -火 曜-

797 : Re:Re:Re:Re:なでしこ3の塗りスタイルは透明、画面クリアは? - TKI さん


今のところは小難しい方法でキャンバスサイズを取ってやらねばなりませんか……
取得ができるなら設定もできるかな、と試したらできました。

ありがとうございました!

//-------------------なでしこ3簡易エディタ
cw = 400
ch = 400
描画中キャンバスの「width」にcwをDOM属性設定。
描画中キャンバスの「height」にchをDOM属性設定。

●画面クリア
  [0,0,cw,ch]の描画クリア
ここまで

透明=「rgba(0,0,0,0)」 //aは0~1。0が透明。
透明に塗色設定

円配列=[]
timer = 0

●円追加
  x=乱数(cw-40)+20
  y=乱数(ch-40)+20
  r=2
  xを円配列に配列追加
  yを円配列に配列追加
  rを円配列に配列追加
ここまで

●円更新
  もしtimer%5が0ならば、円追加。
  timer = timer +1
  画面クリア
  n = 円配列の要素数  //3,6,9…
  1の間
    n = n-3 //9→6→3→0
    もしn<0ならば、抜ける。
    x = 円配列[n]
    y = 円配列[n+1]
    r = 円配列[n+2]
    [x,y]へrの円描画
    r=r+3
    もしr >= 100ならば
      円配列のnから3を配列取出 
    違えば
      円配列[n+2] = r
    ここまで
  ここまで
ここまで

「円更新」を0.1秒毎
//-------------------

(編集パスワード送信)

子記事

親記事 (No.793)
返信した記事(元) (No.796)

この内容(No.797)に返信

この内容(No.797)をダウンロード

この内容(No.797)のテキスト表示


2020-01-13 23:50:45 -月 曜-

796 : Re:Re:Re:なでしこ3の塗りスタイルは透明、画面クリアは? - 雪乃☆雫 さん


 HTMLというかCSSというかの指定方法ですね。
 redとかblueとか、数値ではなくカラーネームで指定出来るようになってる部分を日本語に直して色定数としているんだと思います。
 まだリファレンスが充実しておらずサッパリ分りませんが、お馴染みの16進数(#ff0000)以外にも、RGB(rgb(255,0,0))、RGBA(rgba(255,0,0,1))、HSL(hsl(0,100%,50%))、HSLA(hsla(0,100%,50%,1))などが使えますですよ。
 それとスミマセンまちがえてました。透明度のaの価は、0~1で、0が透明、でした;
 なでしこ3のweb版を使いこなすには現状、HTMLとCSSの知識が不可欠となっており、もう少し庶民にとって便利な機能の充実が望まれるところですケド、JS実行があるのでJavascriptで出来ることは大概出来るんだろうなぁとは思うところです(ワタシにはムリですが(^▽^;)

画面クリアの方は、意味を理解しました☆
現在の描画キャンバスをまるっとクリアしたいが、xywhの指定が必須なのでどうしたらいいかなということですね?
こんな感じ?
#-----------------------------------------------
[0,0,800,600]に四角描画。

w=描画中キャンバスの「width」をDOM属性取得。
h=描画中キャンバスの「height」をDOM属性取得。
「{w},{h}」を表示。

3秒後には
[0,0,w,h]の描画クリア。
#-----------------------------------------------



(編集パスワード送信)

子記事

親記事 (No.793)
返信した記事(元) (No.795)

この内容(No.796)に返信

この内容(No.796)をダウンロード

この内容(No.796)のテキスト表示


2020-01-13 20:42:04 -月 曜-

795 : Re:Re:なでしこ3の塗りスタイルは透明、画面クリアは? - TKI さん


回答ありがとうございます
その色指定の方法は見たことがなかったです。
HTMLの書き方なのかな?
ためしに「赤色を表示」するとredと文字が表示されたりしますね。 数値じゃないんだ…
透明色は解決です。

画面クリアのほうは適当なサイズを指定しているだけです。
キャンバスのサイズを取ってきてるわけでもないので、全部消したつもりが残ったりするやつ。
簡単確実に端まで消す方法があれば使いたいなー、と。

(編集パスワード送信)

子記事

親記事 (No.793)
返信した記事(元) (No.794)

この内容(No.795)に返信

この内容(No.795)をダウンロード

この内容(No.795)のテキスト表示


2020-01-13 17:15:18 -月 曜-

794 : Re:なでしこ3の塗りスタイルは透明、画面クリアは? - 雪乃☆雫 さん


 おぉ、なでしこ3の質問だ(喜)
 たしかに、色定数で透明とかがあると便利ですよねぇ~。
 でも、なでしこ3では、rgba式で色の指定が出来ますので、実は透明も半透明も自由自在なんです。
 とりあえず、これで透明に塗ることが出来ますよ☆
#-----------------------------------------------
透明=「rgba(0,0,0,0)」 //aは0~100。0が透明。
赤色に塗色設定
[50,50]へ40の円描画
透明に塗色設定
[80,80]へ30の円描画
#-----------------------------------------------

 描画クリアは、あれでうまくいってないですか?
 出来ていると思うのですが。
 やりたいことが違うのかな???

(編集パスワード送信)

子記事

親記事 (No.793)
返信した記事(元) (No.793)

この内容(No.794)に返信

この内容(No.794)をダウンロード

この内容(No.794)のテキスト表示


最新に戻る < < < > > > 次へ




www.eznavi.net