日本語プログラミング言語なでしこの公式掲示板

なでしこ の 掲示板

トップ 最新 新規 検索 公式

2018-04-21 03:56:36 -土 曜-

461 : 解決しました - E.Y さん


解決できました。目印が「●●あいうえ」のように変わっても後半の今日を明日に変換
できました。前半と後半を分けて考えればよかったんですね。ありがとうございました。


A=「今日は、早起きをした。 
今日は、雨でじとじとしていた。 
●●あいうえ 
今日は、遠足です。 
今日は、晴れて、すがすがしい一日であるように願います。 
」 

前半=Aから「●●」まで切り取る 
後半=A 
後半=後半の「今日」を「明日」に置換 
A=前半 & 「●●」 & 後半 
Aを表示

(編集パスワード送信)

子記事

親記事 (No.454)
返信した記事(元) (No.454)

この内容(No.461)に返信

この内容(No.461)をダウンロード

この内容(No.461)のテキスト表示


2018-04-20 22:52:31 -金 曜-

460 : Re:GUIとは関係ない所で、クリックするまで待機したい - とけい さん


キー状態の命令でマウスボタンの状態は取得できます。
キー状態(1)でマウスの左ボタン
キー状態(2)でマウスの右ボタン
キー状態(4)でマウスの中ボタンが取得できます。

厳密にはクリックではないですが、こんな感じで。
#-----------------------------------------------ここから
母艦のサイズは「0,0,200,100」
1でループ
 もしキー状態(1)==1ならば抜ける//ボタンを押している
 0.05秒待つ
1でループ
 もしキー状態(1)==0ならば抜ける//ボタンを離している
 0.05秒待つ
「マウス離したよ」と表示
#-----------------------------------------------ここまで

操作したつもりじゃなくてもプログラムが進むので扱いにくいかもしれません。



小さい母艦を最前面にして
手順2が終わったらボタンをクリックして進むほうが使いやすいかも。
#-----------------------------------------------ここから
母艦のサイズは「0,0,200,100」
母艦を最前面
手順3ボタンとはボタン
#-----------------------------------------------ここまで

(編集パスワード送信)

子記事

親記事 (No.456)
返信した記事(元) (No.456)

この内容(No.460)に返信

この内容(No.460)をダウンロード

この内容(No.460)のテキスト表示


2018-04-20 22:47:13 -金 曜-

459 : Re:指定されたバイト数以上にある単語を置換 - とけい さん


前半と後半を別々の変数に入れて、作業が終わったらくっつけるのが早そう

#-------------------------------------ここから

A=「今日は、早起きをした。
今日は、雨でじとじとしていた。
●●
今日は、遠足です。
今日は、晴れて、すがすがしい一日であるように願います。


前半=Aから「●●」まで切り取る
後半=A
後半=後半の「今日」を「明日」に置換
A=前半 & 「●●」 & 後半
Aを表示

(編集パスワード送信)

子記事

親記事 (No.454)
返信した記事(元) (No.454)

この内容(No.459)に返信

この内容(No.459)をダウンロード

この内容(No.459)のテキスト表示


2018-04-20 18:10:45 -金 曜-

458 : 早急の教えありがとうございます。 - E.Y さん


 UNOパパ さん早急に対応していただきありがとうございます。●●以上の
置換ですが、これができればある条件に当てはまる文字以上の置換ができ
とっても便利だなと思い質問しました。現在教えてもらった方法で置換
しましたが、●●以上の置換ができないので、もしの使い方で試行錯誤
していますが解決していません。お忙しい中本当にありがとうございました。

(編集パスワード送信)

子記事

親記事 (No.454)
返信した記事(元) (No.454)

この内容(No.458)に返信

この内容(No.458)をダウンロード

この内容(No.458)のテキスト表示


2018-04-20 14:17:36 -金 曜-

456 : GUIとは関係ない所で、クリックするまで待機したい - ぎん さん


お世話になります。

例えばYahooトップの検索窓は、検索語句を入力して「Enter」で結果を表示しれくれますが、
入力後マウスで「検索」ボタンを押しても同じ結果が得られます。

同じように、Web上で「検索」ボタンを押すと対応したリストを返してくれるページがあります。
(これは私が作っているものではないのでこれの仕様などは一切不明です。こんなレベルの質問をしている時点でお察しいただけると思いますが)

1.「窓に語句を貼りつけ検索実行」

2.「そのリストから目的の候補の位置にカーソルを動かし、クリック」

3.「次の作業。。」

という流れの作業で、2.だけを人力で行いたいのです。

1.は、元々入力したい語句がクリップボードに入れてあり、
それをマウス座標指定+マウスクリック+キー送信で『^V』で貼りつけることはできますが、

その後検索ボタンにマウス座標指定しマウスクリックで
結果を目視で確認し、
クリックするまで待機、クリックされたら3.以降の次の作業に移りたいのです。

無理でしょうか?
簡単そうなフローなのですが。。

お知恵を拝借できたら光栄です。

(編集パスワード送信)

親記事

この内容(No.456)に返信

この内容(No.456)をダウンロード

この内容(No.456)のテキスト表示

子記事

464 Re:Re:GUIとは関係ない所で、クリックするまで待機したい (18-04-21)
460 Re:GUIとは関係ない所で、クリックするまで待機したい (18-04-20)

戻る < < < > > > 次へ




www.eznavi.net