日本語プログラミング言語なでしこの公式掲示板

なでしこ の 掲示板

トップ 最新 新規 検索 公式

2018-05-09 10:43:11 -水 曜-

467 : 新しい方法教えてくださりありがとうございました。 - E.Y さん


まっちゃんさん、新しい方法教えてくださりありがとうございました。
😄まさしくその通りになりました。感謝します。これを使うと目印から
以後の指定された文字をカウントを数えたり、応用がとても広がります。



(編集パスワード送信)

子記事

親記事 (No.454)
返信した記事(元) (No.454)

この内容(No.467)に返信

この内容(No.467)をダウンロード

この内容(No.467)のテキスト表示


2018-05-07 14:37:23 -月 曜-

466 : Re:指定されたバイト数以上にある単語を置換 - まっちゃん さん


こんにちは。

>> 下のように今日という文字が4つあるとします。●●の文字数以上にある「今日」を「明日」に置換する方法を教えてください。

以下のように二つに分けてみてはいかがでしょうか。

#ソースコードここから
A=「今日は、早起きをした。
今日は、雨でじとじとしていた。
●●
今日は、遠足です。 
今日は、晴れて、すがすがしい一日であるように願います。 
」 
Moji=Aで「●●」が何文字目

AA=Aの1から(Moji)文字抜き出す
BB=Aの1から(Moji)文字削除

// AAは目印の前
// BBは目印より後ろ

BB=BBの「今日」を「明日」に置換

結果=AA&BB
結果を言う
#ここまで


文字数ではなく、単に目印の後ろを置換するだけならば、「切り取る」命令を使うこともできます。

#ここから
A=「今日は、早起きをした。 
今日は、雨でじとじとしていた。 
●●
今日は、遠足です。 
今日は、晴れて、すがすがしい一日であるように願います。 
」 

BB=A
AA=BBから「●●」まで切り取る
// AAは目印の前
// BBは目印より後ろ

BB=BBの「今日」を「明日」に置換

結果=AA&「●●」&BB
結果を言う
#ここまで



(編集パスワード送信)

子記事

親記事 (No.454)
返信した記事(元) (No.454)

この内容(No.466)に返信

この内容(No.466)をダウンロード

この内容(No.466)のテキスト表示


2018-04-25 10:42:31 -水 曜-

465 : Re:Re:スプリッタが動きません - とら さん


助かりました!
貴重な情報ありがとうございます!

(編集パスワード送信)

子記事

親記事 (No.452)
返信した記事(元) (No.453)

この内容(No.465)に返信

この内容(No.465)をダウンロード

この内容(No.465)のテキスト表示


2018-04-21 23:11:47 -土 曜-

464 : Re:Re:GUIとは関係ない所で、クリックするまで待機したい - ぎん さん


ありがとうございます。
キー状態、そういう指示もあるのですね。
曖昧な説明にもかかわらず
しっかり意図する作業に合致しました。とてもありがたいです。

キー状態の命令でマウスボタンの状態は取得できます。
キー状態(1)でマウスの左ボタン
キー状態(2)でマウスの右ボタン
キー状態(4)でマウスの中ボタンが取得できます。

厳密にはクリックではないですが、こんな感じで。
#-----------------------------------------------ここから
母艦のサイズは「0,0,200,100」
1でループ
 もしキー状態(1)==1ならば抜ける//ボタンを押している
 0.05秒待つ
1でループ
 もしキー状態(1)==0ならば抜ける//ボタンを離している
 0.05秒待つ
「マウス離したよ」と表示
#-----------------------------------------------ここまで

操作したつもりじゃなくてもプログラムが進むので扱いにくいかもしれません。



小さい母艦を最前面にして
手順2が終わったらボタンをクリックして進むほうが使いやすいかも。
#-----------------------------------------------ここから
母艦のサイズは「0,0,200,100」
母艦を最前面
手順3ボタンとはボタン
#-----------------------------------------------ここまで


(編集パスワード送信)

子記事

親記事 (No.456)
返信した記事(元) (No.460)

この内容(No.464)に返信

この内容(No.464)をダウンロード

この内容(No.464)のテキスト表示


2018-04-21 16:01:05 -土 曜-

463 : Re:Re:(バグ?)積み木エディタにてオブジェクトの正常な生成ができない - mkm75 さん


遅くなってしまい申し訳ございません。
ありがとうございます。
名前を変更してみたところ、無事に動きました。

(編集パスワード送信)

子記事

親記事 (No.446)
返信した記事(元) (No.447)

この内容(No.463)に返信

この内容(No.463)をダウンロード

この内容(No.463)のテキスト表示


戻る < < < > > > 次へ




www.eznavi.net