日本語プログラミング言語なでしこの公式掲示板

なでしこ の 掲示板

トップ 最新 新規 検索 公式


2018-06-05 19:44:25 -火 曜-

480 : 窓ハンドル検索・窓ハンドルアクティブは不安定なものなのでしょうか - ぎん さん


たびたびお世話になります。分からないことだらけですみません。

タイトルの通りなのですが、窓ハンドルを検索しアクティブにしたいのですが、
できる時とできない時とあります。
できない時:開いているにもかかわらずアクティブになってくれない

命令は同じで、

#----------ここから
ハンドル=「*NADE BBS*」を窓ハンドル検索
ハンドルを言う

もしハンドル>0ならば、
ハンドルを窓ハンドルアクティブ
違えば、
「IE開いていないよ」と言う
#----------ここまで
といった感じです。
IEにはYahooとGoogleとこのNADE BBSが開いているとして、NADE BBSをアクティブにしたいんです。
実証前に、ウィンドウ列挙してタイトルに入っていることを確認済みです。

ブラウザはIEで、複数タブを開いている場合でも、
タブに書いてあるのがタイトルと判断していいと思うのですが、、。

関連性として思いつくもの
母艦の可視の設定?(オフにしてしまうとうまくいかないことが多い気がする)
根本的な誤りがあるのか、
ハード面での問題か(PC立ち上げ直後だとうまくいくことが多いですが、2・3回やるとダメです。
メモリを大量に食ったりするんでしょうか)
たとえば「キー送信」系なら、命令後に「○秒待つ」のが常識みたいな感じですが、
窓ハンドル系の命令も何かそういう、みなさんにとっては常識的な+αのルールがあるのでしょうか?

どなたかお力添えをお願いいたします。

(編集パスワード送信)

親記事

この内容(No.480)に返信

この内容(No.480)をダウンロード

この内容(No.480)のテキスト表示

◎ 画像ファイル

子記事

496 Re:試してみました(その1) (18-06-13)
492 試してみました(その1) (18-06-12)
489 Re:連投すみません (18-06-09)
488 Re:窓ハンドル検索・窓ハンドルアクティブは不安定なものなのでしょうか (18-06-09)
487 連投すみません (18-06-08)
486 Re:Re:Re:環境を教えてください (18-06-08)
485 Re:Re:環境を教えてください (18-06-08)
484 Re:環境を教えてください (18-06-08)
483 Re:Re:窓ハンドル検索・窓ハンドルアクティブは不安定なものなのでしょうか (18-06-08)
482 環境を教えてください (18-06-06)
481 Re:窓ハンドル検索・窓ハンドルアクティブは不安定なものなのでしょうか (18-06-05)




www.eznavi.net