EZNAVI.net


令和7年度(2025年)以降の大学共通テスト(試験センター試験)のプログラミング問題をなでしこで解いてみる🎊


令和7年度以降の大学共通テスト(センター試験)、「情報」には、プログラミングを解く問題があります💨
そこで日本語プログラミング言語なでしこで解いてみました😉
疑似言語でしたが解いてみたところ、日本語プログラミング言語なでしこで近い書き方で書くことができ動作します🤞
ぜひ見てみてくださいね🎀



例題をなでしこで解いて動作させる(1)


👇こちらで日本語プログラミング言語なでしこが動作します。👇

日本語プログラミング言語 なでしこ3

👇こちらは令和7年度以降の大学共通テストの例題プログラムです👇

(01) Tomei = ["A 党","B 党","C 党","D 党"]
(02) Tokuhyo = [1200,660,1440,180]
(03) sousuu = 0
(04) giseki = 6
(05) m を 0 から 3 まで 1 ずつ増やしながら繰り返す:
(06)⎿sousuu = sousuu + Tokuhyo[m]
(07) kizyunsuu = sousuu / giseki
(08) 表示する("基準得票数:",kizyunsuu )
(09) 表示する("比例配分")
(10) m を 0 から 3 まで 1 ずつ増やしながら繰り返す:
(11)⎿表示する(Tomei[m],":", Tokuhyo[m] /kizyunsuu)



例題をなでしこで解いて動作させる(2)


👇こちらで日本語プログラミング言語なでしこが動作します。👇

日本語プログラミング言語 なでしこ3

👇こちらは令和7年度以降の大学共通テストの例題プログラムです👇

(01) Tomei = ["A 党","B 党","C 党","D 党"]
(02) Tokuhyo = [1200,660,1440,180]
(03) Tosen = [0,0,0,0]
(04) tosenkei = 0
(05) giseki = 6
(06) m を 0 から 3まで 1 ずつ増やしながら繰り返す:
(07)⎿ Hikaku[m] = Tokuhyo[m]
(08) tosenkei < giseki の間繰り返す:
(09)| max = 0
(10)| i を 0 から 3 まで 1 ずつ増やしながら繰り返す:
(11)| | もし max < Hikaku[i]ならば:
(12)| | |max = Hikaku[i]
(13)| ⎿ ⎿ maxi = i
(14)| Tosen[maxi] = Tosen[maxi] + 1
(15)| tosenkei = tosenkei + 1
(16)⎿Hikaku[maxi] = 切り捨て( Tokuhyo[maxi] / (Tosen[maxi] + 1))
(17) k を 0 から 3まで 1 ずつ増やしながら繰り返す:
(18)⎿表示する(Tomei[k],":",Tosen[k],"名")



問題の詳細は以下よりご確認ください。

平成30年告示高等学校学習指導要領に対応した令和7年度大学入学共通テストからの出題教科・科目があります。
「情報」の中に、疑似言語としてプログラミングを題材とした問題があります⏰

令和7年度以降の試験|大学入試センター





http://www.eznavi.net/index.php?site=ez20210407