日本語プログラミング言語なでしこの公式掲示板

なでしこ1 質問

トップ 新規 検索

new2021-05-17 02:32:52

Re①:仕様でしょうか

ななっしー さん

便乗して^^
わたしも悩みました。

なでしこ3マニュアル > 文法 > 「制御構文」文法/もし > 「もしの単文について」
には
『また、条件分岐の処理が一文(句点や改行まで)で記述できる場合には、「ここまで」を省略することができます』
とありますが、どうやら省略必須のようです。
なので「もし構文」は
『もし、(A=1ならば、){「あ」を表示。}』
と、ここで自動的に閉じてますね(V3で)。

>Sの「\n」を「\r\n」に正規表現置換 
ここはシステム定数を使って
「{CR}{LF}」でしょうか。

(編集パスワード送信)

子記事

親記事 (No.1046)
返信した記事(元) (No.1046)

この内容(No.1047)に返信

この内容(No.1047)をダウンロード

この内容(No.1047)のテキスト表示





www.eznavi.net