日本語プログラミング言語なでしこの公式掲示板

なでしこ 交流

トップ 新規 検索

new2021-05-16 10:22:00

仕様でしょうか

使ってます さん


#なでしこ3を少し使ってみて、わからないところがあり、書かせていただきました。
#動作は、「簡易エディタ」で確認しました。

#その1.


A=0
もし、A=1ならば、「あ」を表示。「い」を表示。#「ここまで」を書くとエラー。

#上の結果は、「い」が表示されます。
#(なでしこ1では、何も表示されません)
#これは、正常な動作なのでしょうか。
#!インデント構文 を文頭につけても、同じ動作でした。
#仕様でしたら、それを踏まえて使わせて頂きます。


#その2

S=「あいうえ
かきくけ」

Sの「\n」を「\r\n」に正規表現置換

それを表示

#上の結果は、「あいうえ\r\nかきくけ」でした
#「\r\n」の部分が、そのまま文字列として処理されています。
#「\r\n」の部分が「\t」などでも同様に、そのまま文字列として処理されます。
#なでしこ1のときのような動作で正規表現置換したいときは
#どうしたらいいでしょうか


(編集パスワード送信)

親記事

この内容(No.1046)に返信

この内容(No.1046)をダウンロード

この内容(No.1046)のテキスト表示





www.eznavi.net